Last updated December 29, 2003

Schedule + Won't Print Outlook Private Appointments [Q183650]

PSS ID Number: Q183650
Article last modified on 09-09-1999

WINDOWS:7.0,7.5


The information in this article applies to:
- Microsoft Schedule+, versions 7.0, 7.5


SYMPTOMS
You cannot use Microsoft Schedule+ 7.0, Schedule+ 7.5, or Schedule+ 95 (Schedule+ 7.x) to print or preview private appointments, contained in a Microsoft Outlook calendar.

Attempting to print an Outlook calendar from Schedule+, returns no error message, but the private appointments do not print.

Attempting to preview an Outlook calendar from Schedule+, returns the following error message:

The print operation could not be completed. Your computer is out of memory.

CAUSE
When a Schedule+ client prints or previews an Outlook calendar, it receives an error of MAPI_E_NO_ACCESS on the private appointments and module Msoutl32.dll mishandles the private appointments.

RESOLUTION
To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For more information, please see the following article in the Microsoft Knowledge Base:
Q191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

STATUS
Microsoft has confirmed this to be a problem in Schedule+ 7.x. This problem was first corrected in Exchange Server 5.5 Service Pack 2.

MORE INFORMATION
Schedule+ 7.x cannot read an Outlook calendar without the Outlook calendar access patch for Schedule+ 7.x. This patch is available from the Microsoft Web site at: Sp2_55su.EXE
(http://support.microsoft.com/download/support/mslfiles/Msoutl.exe)
[The link to the MS website has died, therefor I replaced it with a link to the MS FTP-site -- Remark CB]

The accompanying Readme-file says:
-----------------------------------------------------------------------
Installing Service Pack 2 for Microsoft Exchange Client Support Files from the Compressed File
-----------------------------------------------------------------------

1. Create an SP2 directory (or use existing).

2. Download the client support file SP2_55SU.exe into the SP2 directory.

3. At the Windows NT command prompt, switch to the unpack location, and type the file name to bring up the Self-extracting menu. From the menu select the folder in which to unzip the files.

The client support file includes the following five directories under the SP2\\Support directory:

- The Language pack. Located in the SP2\\Support\Langpack\Nta and SP2\\Support\Langpack\Ntx directory.

- The Schedule+ Exchange Transport DLL installation program. Located in the SP2\\Msoutl directory. This driver enables you to open Microsoft Outlook calendars from within Schedule+ 7.x. It works only with Windows NT or Windows 95 versions of Schedule+ 7.x. You must also be using Microsoft Exchange Server.

After the driver is installed, the Schedule+ user can open an Outlook user's calendar (Open command, File menu, Open Other's Appointment Book submenu). The Schedule+ user must have Read permissions for the Outlook user's calendar, and that calendar must be stored on a Microsoft Exchange Server.

NOTE: The Schedule+ user can only read the Outlook user's calendar, not add to or edit it, regardless of the permissions granted by the Outlook user.

REFERENCES
For more information on the Outlook calendar access patch for Schedule+ 7.x, please see the following article in the Microsoft Knowledge Base:
Q170061 Readme.txt for Msoutl32.dll


Version : WINDOWS:7.0,7.5
Platform : WINDOWS


Copyright Microsoft Corporation 1999.

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