Last updated December 29, 2003

OL97: Error Converting Outlook Contacts to Schedule+ [Q166380]

PSS ID Number: Q166380
Article last modified on 09-10-1999


The information in this article applies to:
- Microsoft Outlook 97

When importing Microsoft Outlook 97 Contacts into Microsoft Schedule+ 7.0, you may get one of the following error messages:

The import file has too many fields. Make sure the character you selected to separate the fields matches the separator in the import file and that you select the correct character to surround strings.


There was a problem importing the file. The problem occurred near line x.

Outlook stores much more information about contacts than Schedule+. If you export the entire Outlook data set, this generates more fields than the Schedule+ importer can handle. Also, if a date field is empty, it is exported as 0/0/00, which is not acceptable to Schedule+.

To correct this problem, export only those fields that can be imported into Schedule+. Then import the file into Microsoft Excel for an interim cleanup step. In Microsoft Excel, remove any empty date fields and any completely unused columns.

To Export Contacts From Outlook
1. On Outlook's, File menu click Import and Export.
2. Click "Export to a File" and click Next.
3. Click the Contact folder you want to export and click Next.
4. Click "Comma Separated Values (Windows)" and click Next.
5. Type a path and file name for the file to be exported and click Next.
6. Click "Map Custom Fields...".
7. Click Clear Map.
8. Drag the following fields from the left pane to the right pane:

Assistant's Name
Assistant's Phone
Business City
Business Country
Business Phone
Business Phone2
Business Postal Code
Business State
Business Street (NOTE: Not "Business Address")
Business Fax or Home Fax or Other Fax (NOTE: Schedule+ only supports one "fax" field)
First Name
Home City
Home Country
Home Phone
Home Phone 2
Home Postal Code
Home State
Home Street (NOTE: Not "Home Address")
Last Name
Mobile Phone
User 1
User 2
User 3
User 4

NOTE: If User 1, User 2, User 3 and User 4 are not used in Outlook, any other four fields may be substituted.

9. Click OK and Finish.
NOTE: Outlook stores these settings for the specific format and export item type, in this case "Comma Separated Values (Windows)" and Contact items. Subsequent exports using this same format and item type will already have the same mapped fields.

To Import and Manipulate Contacts in Microsoft Excel
1. On Microsoft Excel's File menu, click Open.
2. Navigate to the file exported above and click Open.
3. On the Edit menu, click Replace.
4. Type 0/0/00 in Find What.
5. Leave Replace With, empty.
6. Click Replace All.
7. Select any completely unused columns and on the Edit menu, click Delete.
8. On the File menu, click Close, click Yes, and then click Save to replace the existing file.

To Import Contacts to Schedule+
1. On the Schedule+ File menu, point to Import and click Text.
2. Type or Browse to the file name to be imported, then click Next.
3. Click Yes and then click Next.
4. Click Comma, select the quotation mark (") as "character used to surround text fields", and click Next.
5. Click Contact List and click Next.
6. Select types for each field in the incoming file.
7. Click Finish.
NOTE: Once set, Schedule+ retains these settings.

For information on exporting Outlook Appointments to Schedule+, please see the following article(s)in the Microsoft Knowledge Base:

Q166307 OL97: How to Convert Outlook Appointments to Schedule+ 7.0

Version : WINDOWS:97
Platform : WINDOWS

Copyright Microsoft Corporation 1999.

back to top

<- back to 'Schedule+, Exchange Cient and Outlook - interoperability'